Page 1 of 1

Error code 354

PostPosted: Sun Mar 19, 2017 6:36 am
by FJ04EJC
Just retrieved the '1000 from the garage and assumed the battery was flat. However found it was fully charged but nothing will work. Key goes in the ignition and all lights up as normal until I try and use anything electrical - immediately get error code 354. Indicators, lights, brake lights - everything trips it. Thinking could be a short somewhere in the the loom or ECU? The bike was fine when it went into storage in October. Any help/clues would be gratefully received!

Re: Error code 354

PostPosted: Sun Mar 19, 2017 7:19 am
by MJ310
I think that error code is ignition coils. Have you tried to start it? What model do you have?

Re: Error code 354

PostPosted: Sun Mar 19, 2017 7:30 am
by FJ04EJC
It's a 1000S 2003 build. I'm going to try a new battery although the existing one is only about three years old. I changed the ignition coils about four years ago.

Re: Error code 354

PostPosted: Sun Mar 19, 2017 11:15 pm
by DAVID THOMPSON
try unplugging and replugging the connectors in the harness with care
with no battery installed

my rt125 gets confused some times from poor connections in its harness

and i have had some problems in resent years with bad fuses that check good with a meter
on both bikes and amateur radio gear but are bad

test the fuses with a 194 marker bulb in series with a battery
to make sure its really good
also fuse contacts get dirty and some times just need un plugged and plugged back in

mz uses Diodes in circuits i am not familiar with the 1000 wiring but if it has some of these diodes and there bad
all kinds of funny things can happen

and a good look that every thing is plugged in

my son had a mower that would not start a shovel had fell over and knocked the spark plug wire off the plug stupid stuff wrong is hard to find

when you sort it out let us know what it is and what the code means if its known
Dave

Re: Error code 354

PostPosted: Mon Mar 20, 2017 5:49 am
by MJ310
According to the manual there is no error code PO354 that I can find. PO351 and PO352 are the coils but I think it's in the right area. I would do as David suggests but in the ignition area first, coils, CPU and timing control. Do you have a factory manual?

Re: Error code 354

PostPosted: Mon Mar 20, 2017 7:33 am
by FJ04EJC
Thanks all. Awaiting a new battery to see if that helps. If not it may take a while to diagnose.

Re: Error code 354

PostPosted: Mon Mar 20, 2017 12:57 pm
by silver MZ-1000s
Hi . Make sure that all negative electrical connections are tight ! I used to get this code often with my previous 1000s . It come out to be a negative wire loose . The wire is located behind a starter on tight to the engine , make sure that is connected right , if that is not the case , check your starter if the screws are tight on it ,