No ignition on Traveller

Black Panther/Street Moto, Baghira, Enduro, Mastiff, Skorpion Traveller and Tour.

Moderators: DAVID THOMPSON, phlat65

No ignition on Traveller

Postby dickl » Thu Jul 20, 2017 11:46 am

Can anyone help with a problem with my Traveller? It has been off the road for 6 long months (I've been using the K75 and/or Replika). I ran the carbs dry and drained the tank before disconnecting the battery. I have filled up with fresh petrol, charged and connected the battery. I have side & main lights plus high beam, rear lights work so do both brake lights, and the indicators work. However, the horn doesn't, there are no warning lights coming on and nothing when the starter button is pushed. I have changed all three fuses, checked that the side stand switch "clicks" when the side stand is up, and "rocked" the engine via the back wheel in top. The bike is in neutral......what should I check next?
Thanks in advance,
Dickl
dickl
 
Posts: 71
Joined: Thu Aug 12, 2010 5:51 am
Location: Warwickshire

Re: No ignition on Traveller

Postby edfmaniac » Thu Jul 20, 2017 12:43 pm

Possibly in the ignition switch itself? I can't remember how many positions it has since mine has been converted to a no key set up for more than a couple of years. I can't imagine any of the safety switches in the trans or side stand effecting your horn.
01 Skorpion Traveler 660
edfmaniac
 
Posts: 763
Joined: Tue Jun 21, 2011 10:56 pm
Location: Austin, TX

Re: No ignition on Traveller

Postby DAVID THOMPSON » Thu Jul 20, 2017 3:52 pm

this is drawing click on it for bigger view
ingandstart.jpg
ingandstart.jpg (16.93 KiB) Viewed 1174 times
Dave 2002 MZ RT125 +1995 Saxon Tour (rotax500cc)
1997 MZ Skorpion Traveller added 6/13/09
Located in WV USA first rode a moped in 1955
"I like the road less traveled if it's PAVED!"
E mail wd8cyv at yahoo dot com
User avatar
DAVID THOMPSON
Moderator
 
Posts: 4536
Joined: Sun Nov 23, 2003 11:01 am
Location: Parkersburg, West Virginia USA .questions answered MZ 95 up, BMW 1953 to 1979 and ham radio WD8CYV

Re: No ignition on Traveller

Postby DAVID THOMPSON » Thu Jul 20, 2017 4:33 pm

horn is usually hot and grounded to beep

some bikes have a big black neg wire but also a small brown wire did the brown wire get missed on the neg post
Dave 2002 MZ RT125 +1995 Saxon Tour (rotax500cc)
1997 MZ Skorpion Traveller added 6/13/09
Located in WV USA first rode a moped in 1955
"I like the road less traveled if it's PAVED!"
E mail wd8cyv at yahoo dot com
User avatar
DAVID THOMPSON
Moderator
 
Posts: 4536
Joined: Sun Nov 23, 2003 11:01 am
Location: Parkersburg, West Virginia USA .questions answered MZ 95 up, BMW 1953 to 1979 and ham radio WD8CYV

Re: No ignition on Traveller

Postby dickl » Sun Jul 23, 2017 3:57 pm

After a couple of hours in the garage, I removed a relay from the Replika (having removed some of the fairing!) and transplanted it to the Traveller and......BINGO the engine now turns over!! I need to sort out and free the choke cable which is sticking, or it could be the mechanism at the carburettor. At least we have some progress, although none of the "dashboard"/warning lights work. I have attached 'photos of the part I swapped over, is it a starter relay?
Attachments
mzrelay 003.JPG
mzrelay 002.JPG
dickl
 
Posts: 71
Joined: Thu Aug 12, 2010 5:51 am
Location: Warwickshire

Re: No ignition on Traveller

Postby DAVID THOMPSON » Sun Jul 23, 2017 4:19 pm

it is the famous relay 30 on 660 bikes or relay 19 on the 125 cc bikes

and an accessory relay at the parts store tell counter guy RL-44

shown lower middle of drawing above

solenoid is upper left it starts bike and is a bit bigger than a golf ball
Dave

https://shop.advanceautoparts.com/p/nov ... 10719355-P
Dave 2002 MZ RT125 +1995 Saxon Tour (rotax500cc)
1997 MZ Skorpion Traveller added 6/13/09
Located in WV USA first rode a moped in 1955
"I like the road less traveled if it's PAVED!"
E mail wd8cyv at yahoo dot com
User avatar
DAVID THOMPSON
Moderator
 
Posts: 4536
Joined: Sun Nov 23, 2003 11:01 am
Location: Parkersburg, West Virginia USA .questions answered MZ 95 up, BMW 1953 to 1979 and ham radio WD8CYV

Re: No ignition on Traveller

Postby edfmaniac » Mon Jul 24, 2017 5:15 am

dickl wrote: I need to sort out and free the choke cable which is sticking, or it could be the mechanism at the carburettor.


Delete the cable and put a plunger style choke on the carb itself. Here's the part number, 2KF1437101.

plungerstarter_big2KF1437101-01_438e.jpg
01 Skorpion Traveler 660
edfmaniac
 
Posts: 763
Joined: Tue Jun 21, 2011 10:56 pm
Location: Austin, TX

Re: No ignition on Traveller

Postby dickl » Mon Jul 24, 2017 4:04 pm

After a few hours I managed to lubricate and free the choke, and the bike started and runs!! :D I will now turn my attention to the horn and warning lights....watch this space! Thanks for the help/advice, I will get a new relay for the Replika (and possibly a spare), the plunger choke seems like a good idea, but a bit pricey.
dickl
 
Posts: 71
Joined: Thu Aug 12, 2010 5:51 am
Location: Warwickshire

Re: No ignition on Traveller

Postby DAVID THOMPSON » Mon Jul 24, 2017 4:41 pm

at the relay the spade lug on the green wire is smaller than the rest needs a little adapter or a bigger lug to fit the rl44

dave
Dave 2002 MZ RT125 +1995 Saxon Tour (rotax500cc)
1997 MZ Skorpion Traveller added 6/13/09
Located in WV USA first rode a moped in 1955
"I like the road less traveled if it's PAVED!"
E mail wd8cyv at yahoo dot com
User avatar
DAVID THOMPSON
Moderator
 
Posts: 4536
Joined: Sun Nov 23, 2003 11:01 am
Location: Parkersburg, West Virginia USA .questions answered MZ 95 up, BMW 1953 to 1979 and ham radio WD8CYV

Re: No ignition on Traveller

Postby edfmaniac » Mon Jul 24, 2017 7:10 pm

dickl wrote:After a few hours I managed to lubricate and free the choke, and the bike started and runs!! :D I will now turn my attention to the horn and warning lights....watch this space! Thanks for the help/advice, I will get a new relay for the Replika (and possibly a spare), the plunger choke seems like a good idea, but a bit pricey.


It's a nice upgrade in my opinion. Never worry about choke cable maintenance again, and if you are doing a lot of tuning like I was, one less thing to take off and put back on every time you pull the carbs.
01 Skorpion Traveler 660
edfmaniac
 
Posts: 763
Joined: Tue Jun 21, 2011 10:56 pm
Location: Austin, TX

Re: No ignition on Traveller

Postby breakwellmz » Wed Jul 26, 2017 3:18 am

A stainless inner cable running in decent bicycle brake or gear outer and you shouldn`t have any problems, what bikes don`t like is not being used.
I replaced my choke lever with a friction cycle gear lever which is much more usable-
Attachments
MZ Handguards etc 001 (Small).jpg
breakwellmz
 
Posts: 408
Joined: Sun Dec 16, 2007 7:11 am
Location: SW England

Re: No ignition on Traveller

Postby dickl » Fri Jul 28, 2017 9:25 am

The new relay arrived today (£2.49 including p & P!!). I have tested it and it works fine; one small question, when I came to fix it in its final position, I noticed that after a couple of moments with the engine running that it had got a little warm. Is this normal? :?
dickl
 
Posts: 71
Joined: Thu Aug 12, 2010 5:51 am
Location: Warwickshire

Re: No ignition on Traveller

Postby DAVID THOMPSON » Fri Jul 28, 2017 10:55 am

if its the stock one it will be very warm because its to small for the job its doing

but any relay will be warm as ALL the power to run the bike passes thru the relay contacts

plus the coil inside is on all the time and produces heat as a results of being on

dave

a toggle switch would work here but then all the safety features of the bike would be bypassed
Dave 2002 MZ RT125 +1995 Saxon Tour (rotax500cc)
1997 MZ Skorpion Traveller added 6/13/09
Located in WV USA first rode a moped in 1955
"I like the road less traveled if it's PAVED!"
E mail wd8cyv at yahoo dot com
User avatar
DAVID THOMPSON
Moderator
 
Posts: 4536
Joined: Sun Nov 23, 2003 11:01 am
Location: Parkersburg, West Virginia USA .questions answered MZ 95 up, BMW 1953 to 1979 and ham radio WD8CYV

Re: No ignition on Traveller

Postby dickl » Mon Jul 31, 2017 4:01 pm

Thanks Dave,
The more I learn about bikes, the more I realise I don't know/understand! I really love my bikes and riding them, but I am becoming more aware of my ignorance of mechanical matters. I think it comes from a Grammar school education where "practical" subjects were frowned on! I do enjoy trying my hand at minor problem solving, and with the help of experts such as a lot of you on this forum I can for example sort out a duff starter relay, free a sticky choke plunger and take an educated guess at how to re-wire a replacement headlight unit. If anyone wants to know, I needed to "pair up" both sets of the three wires to each the two bulbs on the MZ two bulb headlight set-up to the single bulb set up on the TRX replacement unit.
Thanks again.
dickl
 
Posts: 71
Joined: Thu Aug 12, 2010 5:51 am
Location: Warwickshire

Re: No ignition on Traveller

Postby DAVID THOMPSON » Mon Jul 31, 2017 4:49 pm

my shop class was 32 houses with dad as the boss and 10 years in 2 way radio and broadcasting plus a bunch of other stuff
Dave 2002 MZ RT125 +1995 Saxon Tour (rotax500cc)
1997 MZ Skorpion Traveller added 6/13/09
Located in WV USA first rode a moped in 1955
"I like the road less traveled if it's PAVED!"
E mail wd8cyv at yahoo dot com
User avatar
DAVID THOMPSON
Moderator
 
Posts: 4536
Joined: Sun Nov 23, 2003 11:01 am
Location: Parkersburg, West Virginia USA .questions answered MZ 95 up, BMW 1953 to 1979 and ham radio WD8CYV


Return to 660 cc

Who is online

Users browsing this forum: No registered users and 4 guests

cron