Fuel issue ?

ETZ(including Kanuni), ETS, ES, TS, IFA-RT, BK, Saxon,

Moderators: DAVID THOMPSON, phlat65

Fuel issue ?

Postby Andy_C » Sun Apr 08, 2018 4:28 am

My ETZ 250 runs absolutley fine apart from cruising at a sustained 60 or more.

The issue is that I can cover a couple of miles at 60 or so and for no reason all of a sudden with no warning the motor will cut out for a few seconds before carrying on as if nothing has hapenned.

If I vary speed beween 50 / 60 it will keep going absolutley fine.

Just wondering if it is a fuel flow issue. I have the standard tap & filter in place, rubber washer in the tap is OK as is the tank vent.

Does anyone else suffer this or have sufered this, if so what is the cure?

Thanks.
Andy_C
 
Posts: 124
Joined: Sun Mar 02, 2014 9:02 am
Location: Somerset

Re: Fuel issue ?

Postby AlanJ » Sun Apr 08, 2018 5:38 am

Hi Andy,
Out of interest does it cut out if you are going at max throttle, say 70, cos if it does then it probably is fuel. If it only happens at 60 it could be related to revs and if that was so then it should do the same thing in 4th gear at the same revs. Just a thought Andy.
Wish you well Alan.
AlanJ
 
Posts: 124
Joined: Wed Jan 27, 2016 11:31 am
Location: Somersham Huntingdon Cambridgeshire

Re: Fuel issue ?

Postby dirtsurfer » Mon Apr 09, 2018 12:14 am

I'd be checking if my coil or plug lead was shorting out somewhere
MZochist
User avatar
dirtsurfer
 
Posts: 31
Joined: Sun Feb 25, 2018 1:11 am

Re: Fuel issue ?

Postby Puffs » Mon Apr 09, 2018 4:40 am

If it feels like it's running lean it could be fuel, but the way you describe it sounds more like an electrical issue (fuse, any connection, ...).
Puffs
 
Posts: 43
Joined: Tue Jan 16, 2018 11:20 am
Location: Ardennes, Belgium.

Re: Fuel issue ?

Postby Andy_C » Mon Apr 09, 2018 12:29 pm

I never ride it at max throttle for extended period of time so do not know if it cuts out at max throttle.

Aside from this tendancy to briefly cut out it runs absolutley fine, and the plug colour looks good so I dont suspect weak running.

I have upgraded the fuses to "blade" types so i dont suspect an electrical fault.

As long as you ease off the throttle a bit, the tendancy to cut out does not happen which is why I suspect fuel flow.

Perhaps I need to check the level in the float bowl.
Andy_C
 
Posts: 124
Joined: Sun Mar 02, 2014 9:02 am
Location: Somerset

Re: Fuel issue ?

Postby breakwellmz » Tue Apr 10, 2018 2:27 am

Float height would be my first call and give the carb a good clean at the same time.Fuel filter?
breakwellmz
 
Posts: 408
Joined: Sun Dec 16, 2007 7:11 am
Location: SW England

Re: Fuel issue ?

Postby Puffs » Tue Apr 10, 2018 3:58 am

An issue I've had on an old bike was that the rubber in the fuel tap had compacted, causing the holes to become smaller & restricting flow. At some stage the flow had reduced so much that after a while of full throttle, it started it run lean, and indeed cut out. But that bike clearly showed signs of running lean.
To diagnose if it's something like that, check the flow (through any filter, if present): just open the tap & let it flow into a suitable can. Let it flow for at least a litre or so, 'cause the other thing that can plug & choke the flow is the fuel tank vent. (Does it also cut out if you ride without fuel cap?).

Of course clean the carb, but why would the level in the bowl go down over time? Yes, a restriction in the flow upstream could cause that, but absent of that it would only come up (float sealing poorly due to wear on seat & needle).

But still, if it's a clean cut out & otherwise running fine (& plug OK), I'd suspect the ignition.
Puffs
 
Posts: 43
Joined: Tue Jan 16, 2018 11:20 am
Location: Ardennes, Belgium.

Re: Fuel issue ?

Postby Blurredman » Tue Apr 10, 2018 4:31 am

When the bike looses power does the ignition turn off??
1979 Suzuki TS185ER - 9,00 miles - Mud :)
1981 Honda CX500B - 77,000 miles - Long Distance :)
1987 MZ ETZ300 - 29,000 miles - Sun :) - Engine just re-built!
1990 MZ ETZ251 - 40,000 miles - Commute :) - Sleeping for a while! 1/2/18

ftp://blurredmanswebsite.ddns.net/Vehicle_Documents/MZ_Documents/
Blurredman
 
Posts: 321
Joined: Sat Feb 09, 2013 3:59 pm

Re: Fuel issue ?

Postby Andy_C » Tue Apr 10, 2018 12:18 pm

Thanks for all the replies - I did replace the rubber washer in the tap a while ago.

I have to admit that if you run the fuel pipe into a container, the fuel does not exactly flow out at a great rate, removing the cap does not seem to improve the flow rate.

I'll see if removing filter increases the rate, I'll also give the float level a check.

I will report back........
Andy_C
 
Posts: 124
Joined: Sun Mar 02, 2014 9:02 am
Location: Somerset

Re: Fuel issue ?

Postby Andy_C » Tue Apr 10, 2018 2:12 pm

Update.

Went out and took a look tonight.

Fuel flow on main tank is about half of that on reserve.

Tank has plenty of fuel in it, removing the filter makes no difference, guessing that it must be something to do with the pipe that sticks out of the tap and into the tank for main fuel tank flow.

Will take a look in due course, in the meantime I'll give it a sustained 60MPH run with it on reserve and see if the cutting out issue dissapears.
Andy_C
 
Posts: 124
Joined: Sun Mar 02, 2014 9:02 am
Location: Somerset

Re: Fuel issue ?

Postby Andy_C » Sun Apr 15, 2018 8:03 am

Further update.

Took it out for a run this morning and wrung it's neck.

Mis-fire has gone - clearly insufficient fuel flow on main.
Andy_C
 
Posts: 124
Joined: Sun Mar 02, 2014 9:02 am
Location: Somerset

Re: Fuel issue ?

Postby dirtsurfer » Sun Apr 15, 2018 4:37 pm

Ah!

I love an easy solution.

Tally Ho!
MZochist
User avatar
dirtsurfer
 
Posts: 31
Joined: Sun Feb 25, 2018 1:11 am


Return to Vintage Motorcycles

Who is online

Users browsing this forum: No registered users and 1 guest

cron